contactus@zeriva.com | 1-855-770-1400  |  GSA # GS-35F-0462W  |  Store Login  |  Portal Login

Layer 2 & Layer 3 Testing

Layer 2 and 3 Testing

Figure 4: Cisco 3750 layer 2 layer 3 testing

Figure 4: Cisco 3750 layer 2 layer 3 testing

Zeriva technicians verify traffic forwarding performance, protocol scalability and service delivery capabilities of switching and routing devices that are used across the enterprise, metro/edge and core. High traffic loads place demands on the hardware and software components of a Layer-2 and layer-3 networking devices. Before deployment, the interfaces for each router or switch—including memory, buffering and scheduling mechanisms, switching and routing tables—must be thoroughly stressed to ensure the device can switch and route traffic from its input buffers to the appropriate output queues at full line rate. Zeriva technicians use a Xena Networks tester to perform stress tests on a device’s data plane and forwarding capability. Many different packet protocols are built with various packet sizes, traffic profiles, offered loads, and other test parameters, and then real-time measurements observe the effect on your router or switch. Additionally, because the Xena Networks test platform can generate and measure Layer-2 or Layer-3 traffic with equal facility, the test is adapted for routers forwarding IP traffic.

Layer 2 Test

Xena 2544 Layer 2 Configuration

sh ur
Switch#sh ur_ __ _run
Switch#sh running-config
Building configuration...

Current configuration : 1445 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ps
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
--More-- _________ _________vlan internal allocation policy ascending
!
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
--More-- _________ _________interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
--More-- _________ _________!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip http server
!
!
!
control-plane
--More-- _________ _________!
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
end

Switch#sh vlan br

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi1/0/1, Gi1/0/2, Gi1/0/3
Gi1/0/4, Gi1/0/5, Gi1/0/6
Gi1/0/7, Gi1/0/8, Gi1/0/9
Gi1/0/10, Gi1/0/11, Gi1/0/12
Gi1/0/13, Gi1/0/14, Gi1/0/15
Gi1/0/16, Gi1/0/17, Gi1/0/18
Gi1/0/19, Gi1/0/20, Gi1/0/21
Gi1/0/22, Gi1/0/23, Gi1/0/24
Gi1/0/25, Gi1/0/26, Gi1/0/27
Gi1/0/28
2 port-1 active
3 port-2 active
4 VLAN0004 active
5 VLAN0005 active
6 VLAN0006 active
7 VLAN0007 active
10 VLAN0010 active
20 VLAN0020 active
30 VLAN0030 active
40 VLAN0040 active
--More-- _________ _________
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
50 VLAN0050 active
60 VLAN0060 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
Switch# _ _sh ip int br
Interface IP-Address OK? Method Status Protocol
Vlan1 unassigned YES NVRAM administratively down down
GigabitEthernet1/0/1 unassigned YES unset up up
GigabitEthernet1/0/2 unassigned YES unset down down
GigabitEthernet1/0/3 unassigned YES unset down down
GigabitEthernet1/0/4 unassigned YES unset down down
GigabitEthernet1/0/5 unassigned YES unset down down
GigabitEthernet1/0/6 unassigned YES unset down down
GigabitEthernet1/0/7 unassigned YES unset down down
GigabitEthernet1/0/8 unassigned YES unset down down
GigabitEthernet1/0/9 unassigned YES unset down down
GigabitEthernet1/0/10 unassigned YES unset down down
GigabitEthernet1/0/11 unassigned YES unset down down
GigabitEthernet1/0/12 unassigned YES unset up up
GigabitEthernet1/0/13 unassigned YES unset down down
GigabitEthernet1/0/14 unassigned YES unset down down
GigabitEthernet1/0/15 unassigned YES unset down down
GigabitEthernet1/0/16 unassigned YES unset down down
GigabitEthernet1/0/17 unassigned YES unset down down
GigabitEthernet1/0/18 unassigned YES unset down down
GigabitEthernet1/0/19 unassigned YES unset down down
GigabitEthernet1/0/20 unassigned YES unset down down
GigabitEthernet1/0/21 unassigned YES unset down down
--More-- _________ _________GigabitEthernet1/0/22 unassigned YES unset down down
GigabitEthernet1/0/23 unassigned YES unset down down
GigabitEthernet1/0/24 unassigned YES unset down down
GigabitEthernet1/0/25 unassigned YES unset down down
GigabitEthernet1/0/26 unassigned YES unset down down
GigabitEthernet1/0/27 unassigned YES unset down down
GigabitEthernet1/0/28 unassigned YES unset down down
Switch# _ _

Layer 2 Test Parameters Xena RFC 2544

Figure 5: Cisco 3750 layer 2 test Xena RFC 2544

Figure 5: Cisco 3750 layer 2 test Xena RFC 2544

The DUT is connected to the Xena Test Platform and test type options are selected. For this test Pairs under Topology is selected and East -> West under direction is selected.

Layer 2 Test Packet Sizes and Test Type

 

Figure 6: Cisco 3750 layer 2 test packet sizes and test type

Figure 6: Cisco 3750 layer 2 test packet sizes and test type

The test type and packet sizes are selected next. In this case Layer 2 (L2) and IEEE Default, respectively.

Layer 2 Test Gateway and IP Information

Figure 7: Cisco 3750 layer 2 test gateway and IP information

Figure 7: Cisco 3750 layer 2 test gateway and IP information

Test modules and ports are selected, and a destination port and a source port are reserved on the Xena tester. Gateway and port IP information are added to match the configuration of the Layer 2 DUT. Then you must provide the Device Under Test the address of simulated ports. On the destination test port, the modifier function is used to define an Ethernet stream containing a range of source MAC addresses to simulate hosts behind the port. Then traffic generation is started to send the traffic from the destination test port to the source test port to teach the DUT the addresses. Traffic Start on the destination port is unlinked from the global Start button to ensure that traffic will keep running and so that the MAC learning table entries in the DUT do not expire.

Layer 2 Test Throughput Parameters Set

Figure 8: Cisco 3750 layer 2 test throughput parameters set

Figure 8: Cisco 3750 layer 2 test throughput parameters set

Test duration and test parameters are set. Test parameters are changed as needed. Test parameters are initially set at 100% to test the maximum throughput based on port and device capacity.

Layer 2 Test Loss Parameters Set

 

Figure 9: Cisco 3750 layer 2 test loss parameters set

Figure 9: Cisco 3750 layer 2 test loss parameters set

Packet loss test is used to determine if an inordinate amount of packets are dropped that could cause data loss or poor VOIP quality. Test duration is set along with packet rate and frame size and results are displayed.

Layer 2 Test Latency Parameters Set

Figure 11: Cisco 3750 layer 2 test latency parameters set

Figure 11: Cisco 3750 layer 2 test latency parameters set

Latency shows packet delay, jitters shows packet latency variability and packet loss is simply shows the number of lost packets. Test duration is set along with packet rate and then frame size and results are displayed.

Layer 2 Test Back-to-Back Parameters Set

Figure 10: Cisco 3750 layer 2 test back to back parameters set

Figure 10: Cisco 3750 layer 2 test back to back parameters set

Missed frames can cause false indications of unreachability. Test is used to determine the extent of data buffering in the DUT. Test duration and packet rate are set and frame size and results are displayed.

Layer 3 Test

Xena 2544 Layer 3 Configuration

sh ru
Router#sh run
Router#sh running-config
Building configuration...

Current configuration : 845 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
!
dot11 syslog
ip source-route
!
!
--More-- _________ _________ip cef
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
--More-- _________ _________!
!
!
!
!
!
voice-card 0
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
interface GigabitEthernet0/0
--More-- _________ _________ ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
--More-- _________ _________!
!
!
mgcp fax t38 ecm
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Router#

Layer 3 Test Parameters Xena RFC 2544

Figure 12: Cisco 3750 layer 3 test parameters Xena RFC 2544

Figure 12: Cisco 3750 layer 3 test parameters Xena RFC 2544

The DUT is connected to the Xena Test Platform and test type options are selected. For this test Pairs under Topology is selected and East -> West under direction is selected.

Layer 3 Test Packet Sizes and Test Type

Figure 13: Cisco 3750 layer 3 test packet sizes and test type

Figure 13: Cisco 3750 layer 3 test packet sizes and test type

The test type and packet sizes are selected next—in this case Layer 2 (L2) and IEEE Default, respectively.

Layer 3 Test Gateway and IP Information

Figure 14: Cisco 3750 layer 3 test gateway and IP information

Figure 14: Cisco 3750 layer 3 test gateway and IP information

Test modules and ports are selected – A destination port and a source port are reserved on the Xena tester. Gateway and port IP information are added to match the configuration of the Layer 2 DUT. Provide the Device Under Test the address of simulated ports - On the destination test port, the modifier function is used to define an Ethernet stream containing a range of source MAC addresses to simulate hosts behind the port. Then traffic generation is started to send the traffic from the destination test port to the source test port to teach the DUT the addresses. Traffic Start on the destination port is unlinked from the global Start button to ensure that traffic will keep running and so that the MAC learning table entries in the DUT do not expire.

Layer 3 Test Throughput Parameters Set

Figure 15: Cisco 3750 layer 3 test throughput parameters set

Figure 15: Cisco 3750 layer 3 test throughput parameters set

Test duration and test parameters are set. Test parameters are changed as needed. Test parameters are initially set at 100% to test the maximum throughput based on port and device capacity.

Layer 3 Test Loss Parameters Set

Figure 16: Cisco 3750 layer 3 test loss parameters set

Figure 16: Cisco 3750 layer 3 test loss parameters set

Packet loss test is used to determine if an inordinate amount of packets are dropped that could cause data loss or poor VOIP quality. Test duration is set along with packet rate and frame size and results are displayed.

Layer 3 Test Latency Parameters Set

Figure 17: Cisco 3750 layer 3 test latency parameters set

Figure 17: Cisco 3750 layer 3 test latency parameters set

Latency shows packet delay, jitters shows packet latency variability and packet loss is simply shows the number of lost packets. Test duration is set along with packet rate and then frame size and results are displayed.

Layer 3 Test Back-to-Back Parameters Set

Figure 18: Cisco 3750 layer 3 test back to back parameters set

Figure 18: Cisco 3750 layer 3 test back to back parameters set

Figure 19: RFC 2544 Test Report page 1

Figure 19: RFC 2544 Test Report page 1

Figure 20: RFC 2544 Test Report page 1

Figure 20: RFC 2544 Test Report page 2

Figure 21: RFC 2544 Test Report page 1

Figure 21: RFC 2544 Test Report page 3

Figure 22: RFC 2544 Test Report page 1

Figure 22: RFC 2544 Test Report page 4

Figure 23: RFC 2544 Test Report page 1

Figure 23: RFC 2544 Test Report page 5

Figure 24: RFC 2544 Test Report page 1

Figure 24: RFC 2544 Test Report page 6

Figure 25: RFC 2544 Test Report page 1

Figure 25: RFC 2544 Test Report page 7

Figure 26: RFC 2544 Test Report page 1

Figure 26: RFC 2544 Test Report page 8

Figure 27: RFC 2544 Test Report page 1

Figure 27: RFC 2544 Test Report page 9

Figure 28: RFC 2544 Test Report page 1

Figure 28: RFC 2544 Test Report page 10

Figure 29: RFC 2544 Test Report page 1

Figure 29: RFC 2544 Test Report page 11

Figure 30: RFC 2544 Test Report page 1

Figure 30: RFC 2544 Test Report page 12

Missed frames can cause false indications of un-reachability. Test is used to determine the extent of data buffering in the DUT. Test duration and packet rate are set and frame size and results are displayed.


McAfee SECURE sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
Email Newsletter LinkedIn
Talk To An Expert

ph: 1-855-770-1400

contactus@zeriva.com

(0)
close